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2 PREFACE  HOW TO USE THIS GUIDE
This guide will teach you how to perform 3D particle tracking using the General Defocusing
Particle Tracking (GDPT) method and GDPTlab, a GUI Matlab implementation of GDPT. If you
are new to GDPT, you may want to start out reading some of the literature listed below. A brief
introduction about hardware and procedures to correctly perform a GDPT measurements is
provided in the following chapter “Making a GDPT measurement”.
GDPTlab is explained through two walkthrough examples. The best way to learn how to use it is
to open Matlab, install the software, and go through the walkthrough examples once. You will
need 2030 min to complete each of them and that should be enough for being able to use the
software by your own. If you need to revise a certain procedure, you can go back to the specific
section where the topic is treated (e.g. calibration or timeseries measurement) through the Index.
Note that going through the Walkthrough Example 1 is a prerequisite for going through
Walkthrough Example 2.
If you have any problem, please read the guide one more time. If the problem persists, please
contact us at 
barnkob@unibw.de
and 
massimiliano.rossi@unibw.de
. Also, please let us know if
you have ideas for improving the GDPTlab software as well as this guide.
Enjoy 3D particle tracking!
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3 MAKING A GDPT MEASUREMENT
3.1 Prepare the experimental setup
The basic equipment needed for a GDPT measurement consists of four main elements: (1) an
objective lens, (2) an illumination source, (3) a digital camera, and (4) tracer particles. If you have
a digital microscope system, you probably have the first three components already. Different
configurations, for instance using standard camera objectives and external illumination, are of
course possible as well.
●

●

●

●

Objective lens.
The objective lens determines the size of your measurement volume. The
field of view (FOV) of the lens determines the size of the measurement volume in the
directions perpendicular to the viewing axis, while the depth of field (DOF) of the lens
determines the size of the measurement volume in the view direction. In particular, the
measurement depth corresponds to the area in which clear defocused particle images can
be taken (not too big, not too dim). Additional optical elements, such as a cylindrical lens,
can be added to manipulate the defocusing images to obtain more reliable results (see
Walkingthrough Example 2).
Illumination source.
The illumination source must provide a uniform and strong
illumination of the measurement volume. In an epifluorescent microscope setup the
measurement volume is directly illuminated through the objective lens (see Figure 1).
Continuous or pulsed lasers, properly expanded, in combination with fluorescent particles
give normally good results (see Lindken et al. 2009 for more details), but standard
microscope light sources in combination with filters works well too.
Digital camera.
In principle any digital camera can be used for GDPT measurements.
The most important features to take into accounts are:
○ Framerate. It must be large enough to properly resolve your flow. For fast flows
PIV cameras (doubleframe) in combination with pulsed laser are normally used.
○ Sensitivity. It is important to have a good signal with short exposure time. If the
exposure time is too long, fast particles will produce streaks and cannot be used for
the evaluation.
○ Resolution. The size of the pixel sensor must be taken into account to have the
proper magnification and resolution. In particular, the particle images should have a
minimum diameter not below 45 pixels.
○ If the camera is operated using rolling shutter (CMOS sensors), particle images
could be distorted at large velocities. Use global shutter to avoid this problem.
T
racer particles.
Best results are obtained with monodispersed spherical particles. For
microscopic applications, fluorescent particles in combination with an epifluorescent
microscope are recommended to reduce background noise and reflections. The size of the
particles depends mostly on the application. Also, for optimal results, the particle diameter
should be smaller than the DOF of the lens. Note also that the particle concentration
cannot be to high to avoid too many overlapping particles in the image.
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NOTE: The GDPTlab software works only with dark field images, that means: dark background,
bright particle images. This is typically obtained using epifluorescent systems or dark field
microscopes. Bright field images (bright background, dark particles) cannot be processed
directly by GDPTlab and must be first inverted with an image preprocessing software. See
section “Processing bright field images” for more information.

Figure 1:
Example of an
epifluorescent microscope setup with
illumination through the objective lens
and use of fluorescent tracer particles.
The GDPT method is not limited to this
type of experimental setups but can
works also on systems using e.g. bright
field imaging.

3.2 Record calibration images
Once your experimental setup is ready, the first step is to take a set of reference images. This will
provide the lookup table between defocused particle images and depth positions that will be used
by the software for the 3D particle tracking.
To record the calibration images:
● Make sure that you use the same setup that you will use for the experiment (lens,
illumination, camera, particles, fluid, window/optical access).
● Make sure that the tracer particles are not moving in the depth direction. In most cases this
can be achieved by waiting until the particles sink to the bottom or float to the top of the
channel, or looking at particles attached to the wall.
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●
●

Find a position in which some particles are present in the FOV but they are sufficiently
separated so that they do not overlap (see the walkthrough examples).
Move the objective lens (or the particles) with constant steps along the depth of the
measurement volume and take one image of the particles at each step as shown in Fig. 2.
If using a microscope with a motorized focus this can normally be done automatically in
few minutes. Make sure that:
○ You include the whole depth of the measurement volume.
○ You begin from a starting position (Z = 0) and you finish to a final position with
incremental steps of fixed length (e.g. from 0 to 100 µm, with steps of 1 µm).
○ Note down if the starting position (Z = 0) corresponds to the bottom or the top of
you measurement volume.
○ Think carefully about how the Zaxis will be oriented in your measurements. This
depends on your setup (inverted or upright microscope) and you calibration
approach. That Z axis orientation between the calibration and measurement will
be inverse for instance in the example shown in Figure 2.

Figure 2:
Sketch of recording a set of calibration images for the GDPT analysis. The
microscope objective is moved to different Zpositions (z1, z2, z3, etc.), while images of
particles (at a fixeddepth position) are recorded.
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NOTE: You must be careful if changes of refractive index between the immersion medium of
the lens, 
n
(usually air) and the one of the working fluid, 
n
(often water) are present. In this
lens
fluid
case, a correction factor equal to 
n
/
n
must be used to account for that. The reason is that
fluid
lens
during the calibration the lens is moving in the immersion fluid and the particles are fixed,
whereas during the experiments the particles are moving in the working fluid and the lens is
fixed. For example, using lens immersed in air and particles in water, and a step of 1 µm in the
calibration will correspond to 1.33 µm during the measurements. See the walkthrough
examples for more information and reference Rossi et al. 2012.

3.3 Record XYcalibration grid
To obtain the XYdisplacements in physical values, you need
to convert your image pixel dimensions to real units, e.g.
micrometers. This is done by acquiring an experimental image
of an object of wellknown physical size, e.g. a 100µmpitch
calibration grid as shown in the figure to the right.

NOTE: The current version of the GDPTlab software is not able to account for perspective
errors or distortions. If you are using large magnification lenses (M > 510) with small DOF this
is probably not an issue for you (the calibration grid looks like the above figure). For different
lenses, the change in magnification across the measurement depth can vary significantly and
must be corrected. See section “Distortion and perspective errors” for more information.

3.4 Record measurement images
Once you have recorded your set of calibration images for the depth determination and a
calibration grid (or similar) for the inplane 
xy
scaling, you are ready to record the actual
measurement images for the 3D particle tracking.
To record the measurement images:
● Make sure that you use the same setup that you used for obtaining the calibration images
(lens, illumination, camera, particles, fluid, window/optical access).
● Make sure that the objective is in the right position for your measurement: you can
measure only particle images which are included in the recorded calibration images.
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●

●

Be sure to use low enough camera exposure or illumination times (in case of pulsed
illumination) to avoid particle image streaks. The illumination power (together with optics
and the observed system) sets a lower limit to the exposure time needed to obtain images
with appropriate signaltonoise ratio. Again, the exposure time sets an upper limit to the
particle velocities in order to avoid particle image streaks.
Be aware of limitations on particle velocities when using cameras in rolling shutter mode,
where the image pixels are not readoff simultaneously. Ideally: do not use the rolling
shutter mode.

NOTE: You do not need to repeat the calibration for each experiment as long as experimental
conditions do not change!
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4 USING THE GDPTlab SOFTWARE
4.1 Installation
The GDPTlab software package comes with a folder named “GDPTlab_code” containing the
program and a folder named “GDPTlab_examples” containing the walkthrough examples. To
install the program you need first a valid version of Matlab2014b or 2015a. The program has not
been tested on earlier versions of Matlab.
To install the program:
●
●

Copy the folder “GDPTlab_code” in your computer.
Add the path to Matlab main folder (e.g. for 2014a, Home > Set Path > Add Folder… >
Save).

To launch the program:
●
●

Open Matlab.
In the Command Window type “GDPTlab”, press enter and the main panel will appear.

Now you are ready for your first walkthrough example!
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4.2 Walkthrough example 1: flow measurement
Description of the experiment
The experiment used for the Walkthrough Example 1 is described in details in Barnkob et al.
2015 (see reference in the preface). Here we study the HagenPoiseuille flow in a rectangular
microchannel of crosssection 380 µm X 100 µm. The imaging setup is as sketched in Figure 1.
The experimental images are recorded as doubleframe images, with a time separation between
the two frames of 30 µs (more information about doubleframes or timeseries recordings are
provided in the information box at pag. 12). Tracer particles were 2 µm polystyrene spheres and
the working fluid was water. The calibration images were taken with steps of 2 µm. The calibration
grid had a pitch of 50 µm. The optics consists of a 20x microscope objective lens working in air.
Load your experimental images
●
●
●

From the main menu go to “Project > Load Images…”.
Select the folder “..\GDPTlab_examples\WalkThroughExample1\Data\” .
Select all the images (ctrl+a) and press open (note that only *.tif images are supported).

●

Use the intensity buttons (
[]
) to adjust the contrast. You can see the pixel intensity counts
on the scale bar on the right.
To move back and forth through the images you can use the navigation buttons (
[]
). Note
that the “Image step” is kept also during the “Run”.

●
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●

Use the image processing tools (
[]
) to mask out part of the picture and to apply smoothing
filters. A mild smoothing is useful to remove Gaussian noise. Larger values of filters can
worsen the measurements if features in the defocused images are smoothed out. For
these measurements use the default values: Gauss Filter 5x5 and Median Filter 3x3.

DRILL: Play with the “Image preprocessing” buttons and see what happens. See the
difference between processed and raw images using the menu (
[]
) in the “Display options”.
Before you proceed, make “Mask Undo”, set the default values for the filters, and press
“Refresh”.

Find the particles using image segmentation

●
●

●

Insert a segmentation threshold in the edit menu (
[]
). The value should be slightly above
the background mean value. For this experiment set the value at 410 counts.
Insert a minimum area for the particle images in the edit menu (
[]
). This will save some
time removing small object that cannot be particles. For this experiment set a value of 100
pixels.
Press “Refresh” to see the results of the segmentation.

DRILL: Try different segmentation values and see what happens. Remember to press
“Refresh” to update the results and keep the checkbox “Segmentation” (
[]
) ticked to see the
results.
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Create your calibration: load images
●
●
●

From the main menu go to “Calibration > Create Calibration…”.
Go to the folder “..\GDPTlab_examples\WalkThroughExample1\Calibration\”.
Select all the images (ctrl+a) and press open (only *.tif images are supported).

●
●

The calibration panel will popup, which looks very similar to the main panel.
As for the experimental images, you need to set proper segmentation values to find the
particles (
[]
). In this case use a segmentation threshold of 340 counts and a minimum area
of 100 pixels.
Press “Refresh” to see the results.

●

NOTE: It can happen that experimental images and calibration images have different intensities
therefore different segmentation values are needed. This is not a problem since the GDPT
looks at the normalized shape of the images.

DRILL: Use the navigation buttons (
[]
) to go through the different images and see how they
change. Remember that a calibration image set is an ordered sequence of defocused images at
different depth positions, therefore the image numbers correspond to Zpositions. Click
“Refresh” to see if the segmentation values work well for all the positions.
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Create your calibration: make the calibration image stack
The calibration image stack consists of a single particle image for each depth position. This is
created automatically by GDPTlab from a group of valid particles. A valid particle must be present
in all the images, from the first to the last frame. Particle tracking (in the timeseries configuration)
is used to connect a given particle between frames. More information about the particle tracking
schemes included in GDPTlab are in the following information box.

Particle tracking schemes in GDPTlab (Tracking dropdown Menu)
Off
 Particle tracking is disabled. A “Run” provides only the position of the particles. The fields

DX, DY, DZ, ID are all zeros. “Toggle frame” is disabled.
DoubleFrame
 This option assumes that you are using double frame images, as in PIV
evaluations. The frames must be organized in a sequential structure: the odd frames are the
first frames and the even frames are the second frames. For instance the first “double frame”
corresponds to frames 12, the second one to frames 34, and so on. The “Image Step” can be
set only as even integers. To see the second frame use “Toggle frame”. The particle tracking is
performed always between one odd frame and the subsequent even frame. This option cannot
be used to produce particle trajectories and the ID field will be always 0.
Example1: If you have 10 frames and “Image Step” of 2, you will get 5 vector fields
corresponding to 12, 34, 56, 78, and 910.
Example2: If you have 10 frames and “Image Step” of 6, you will get 2 vector fields
corresponding to 12, and 78.
TimeSeries
 This option makes a connected correlation between frames, e.g 12, 23, 34,
and so on. You can use “Toggle frame” to move back and forth between the couple of frames
currently selected. The “Image Step” can be set to any integer value. This option will produce
also particle trajectories, noted in the ID field; a trajectory is created when a particle is
recognized to be present in more than two consecutive frames and will get a tag (one integer
for each trajectory) in the ID field.
Example1: If you have 10 frames and “Image Step” of 1, you will get 9 vector fields
corresponding to 12, 23, 34, 45, 56, 67, 78, 89, and 910.
Example2: If you have 10 frames and “Image Step” of 3, you will get 3 vector fields
corresponding to 14, 47, and 710.
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●

●
●
●

●
●
●

●

Set the tracking options (
[]
). The tracking mode is fixed on timeseries. The max and min
displacements DX and DY must be larger than the maximum displacement of the particle
images from one frame to the other. Leave here the default values of +/ 100 pixels.
Push “Run” (
[]
) to perform the particle tracking across all the images.
Tick the “Segmentation” and “Tracks” checkboxes (
[]
). The cyan lines (“Tracks” box) show
the path of one particle across all the images.
Some of the particles are marked with a yellow crossed circle. These are the valid
particles, i.e. the particles tracked in all the images. (If you did everything correctly, you
should get all particles to be valid in this example!)
After the “Run”, if you have valid particles, the “Make cal” button is enabled.
Give a new name to your calibration (
[]
), e.g. “cal_WTE1”.
Before making the calibration, you have to set the “Scale Z” (
[]
). This is a very important
step since you cannot change this value later on. Put here the distance between each
frame multiplied by the refractive index factor (if needed). Write 2.66 µm for this case.
Remember that the “Scale Z” is not affected for different image step (
[]
).
Create your calibration pressing “Make cal”. In the question dialog choose “Take all”.

After the processing has finished you should have a new variable in your Matlab workspace
(cal_WTE1) and a figure summarizing the results of your calibration as the following one:
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Basically, the calibration that you have created was used to measure the actual position of the
particles present in the set of calibration images. The figure reports the measured 
Z
position (blue,
left Yaxis) with the corresponding correlation coefficient 
C
(orange, right Yaxis) as a function of
m
the actual 
Z
position (known from the frame number multiplied by “Scale Z”).
A perfect calibration would give the measured Z equal to the actual Z (black line) with a Cm of 1. If
you did everything correctly, you should get a graph similar to the one in the above figure, which is
pretty good (small deviation from the black line and Cm>0.98).
NOTE: You may have noticed that the particles are moving from frame to frame. In fact, the
particles are lying on the bottom of the channel but are free to move in the XYdirection. This is
not a problem for the calibration as long as they are not moving in the depth direction and stay
within the FOV.

DRILL 1: Try to use a different skip (
[]
) and see how the calibration looks like.
DRILL 2: Select less particles and see what happens. After “Run” and “Make cal”, choose in the
question dialog “Select”. Draw a polygon around one or two particles and doubleclick on the
polygon to enter.
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Create xyscaling
In order to convert the XYcoordinates into real values, you need to create a convertion scale
between image units and real units. This is done using a XYcalibration grid or another feature of
known physical size. The software has an builtin function for obtaining the X and Yscaling,
when using a calibration grid.
●
●
●
●

From the main menu go to “Calibration > Scaling…”.
Go the folder “..\GDPTlab_examples\WalkThroughExample1\Grid\”.
Select the image “Grid_50um.tif”.
The scaling window will pop up.

●
●
●

Press the “Select cross (dot)” (
[]
) and make a square around a cross.
Doubleclick on the square.
Adjust the “Acceptance valid points” (
[]
) until a sufficient number of crosses are marked by
a valid green crossed circle.
Enter the grid size in the “Pitch X (unit)” and “Pitch Y (unit)” fields (
[]
)
, in this case enter 50
in both fields.
Press the “Calculate grid” button (
[]
) and you should obtain the following window.

●
●
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●
●

Press the “Take Values” button (
[]
) in order to transfer the scaling values to the main
panel.
Close the scaling window to proceed to the GDPT evaluation.

NOTE: You can manually insert scaling values in the main panel in case you will not be using a
grid and obtain the scaling values using other approaches (e.g. rulers, channel dimensions,
etc.).

Run the GDPT evaluation
Now you are ready to perform your GDPT evaluation and can go to the main panel. First, you
have to load the calibration.
● From the main menu go to “Calibration > Load Calibration” .
● Select “cal_WTE1” from the menu. Remember that GDTPlab can load only calibrations
that are present in your Matlab workspace. Note that after a calibration is loaded, the
“Depth determination” menu (
[]
) is enabled.
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●

●

●
●

Set the “Depth determination” on and leave the “Cm (min corr. coeff.)” field to 0.8 (
[]
).
Note that the image filters cannot be changed anymore since you need to use the same
ones used for the calibration.
Adjust now the particle tracking parameters (
[]
)
○ Select “Doubleframe”. Note that particle tracking is enabled only in the
“Doubleframe” or “Timeseries” mode.
○ Set the boundaries of the displacements. This is used to put a first filter/validation
to the measurements; for instance in this case one cannot have DX larger than 0
since we have a flow from right to left. Set the following intervals for the present
experiment: DX [40 0], DY [0.5 0.5], DZ [2 2].
Press “Refresh”.
Tick the checkbox “Segmentation”, “Shape”, and “Vectors” (
[]
) and you should get the
following result.

NOTE: If you have a tracking method selected, the “Toggle frame” button (
[]
) is enabled. This
enables to go back and forth through the two images used for the tracking. Use it to check if the
velocity vector correspond to the actual displacement of the particles!
Ok, now you are ready for the run!
● Give a name to your data in the “Output name” edit box. E.g. “dat_WTE1”.
● Press “Run”.
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In the “Display options” you can decide what to see in the image. In particular:
● Segmentation (green). Show the boundaries of the segmentation. Use to check if the
segmentation threshold is correct.
● Shape (yellow  enabled only when a calibration is loaded). It shows the border of the
calibration particle image associated with the particles. Use it to have a qualitative idea if
the method is working properly. If the shape contour does not match with the particle
there is something wrong!
● Vectors (red  enabled only when a tracking method is selected). It shows the
displacement vector of the particle. Use vector scale to adjust the displaying scale of the
vector.
“Segmentation” checkbox

“Shapes” checkbox

“Tracks” checkbox

After the processing has finished you should have a new variable in your Matlab workspace
(dat_WTE1) and a figure summarizing the results of your evaluation as the following one:
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Note that all the variables are in real units, according to the scaling values inserted in “Scale X”,
“Scale Y” and “Scale Z’. Remember that DX, DY and DZ are length and not velocities! If you want
to get velocities, you need to divide the displacements by the time distance between the two
frames.
Congratulations, you have evaluated your first GDPT measurement!!
Data structure and postprocessing
The run result is matlab object class named “cpoint”. If you press “dat_WTE1” in the Matlab
command window and give enter, you will see the properties (corresponding to the output
variables) of the object:

The output variables are nine number arrays all of same sizes corresponding to the number of
particles evaluated:
● X, Y, Z:
particle coordinates
● In:
particle indices
● DX, DY, DZ:
particle displacements
● Cm:
normalized correlation values
● ID:
particle track numbers, i.e. if particle trajectory 2 has a length of
11, the number 2 will appear 11 times in the dat_WTE1.ID
variable.
The syntax to use a variable is name_object.variable (E.g. dat_WTE1.X). If you are not familiar
with matlab objectoriented programming you may want to rearrange the data, for instance
creating single variables (X = dat_WTE1.X; Y = dat_WTE1.Y; and so on).
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NOTE: Remember that GDPTlab does not save any variable/results. Everything that you create
or save in GDPTlab is put in the current Matlab workspace. If you want to retrieve later on these
data, you need to save the variable in a matfile. For instance, you can save your settings using
“Project > Save settings as…”’. A parameter setting object will appear in the workspace. If you
want to keep it after Matlab is closed, you need to save them in a matfile.

DRILL 1: You can use matlab to plot the data in the way you prefer. Try for instance this one:

What do you get?
DRILL 2:You can notice some velocity outliers in the plot. What happens if you process the data
again with a larger Cm?
DRILL 3: Alternative to processing the data again for larger Cm, you can plot only the points for
which Cm > 0.95 using the following:
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4.3 Walkthrough example 2: particle trajectories
NOTE: Do the Walkthrough Example 2 after the Walkthrough Example 1. If you miss
something, go back to Walkthrough Example 1.

Description of the experiment
The experiment used for the Walkthrough Example 2 is an acoustofluidics experiment, where a
piezoelectric transducer drives the bulk acoustic resonances in a microfluidic device. Here we
investigate a 400µm square microchannel in a glass capillary. The observed particles have a
diameter of 1.2 µm; the particles are influenced both by the acoustic radiation force (drive towards
the channel center) as well as the viscous drag from the acoustic streaming (circulating flow rolls).
The working fluid was in this case water. For more information on this type of phenomena, have a
look in Antfolk et al. (Lab Chip, 2014, 
14
, 27912799).
The imaging setup is as sketched in Figure 1. The illumination was done using a continuous laser
and the experimental images were recorded in timeseries, i.e. the frames are connected
continuously and we will be able to record particles trajectories in contrast to doubleframe image
recordings. Furthermore, the measurements were carried out using an astigmatic system so that
the particle images have elliptical shapes. The advantages of this approach will not be discussed
here. The images were taken with at 10 fps. The calibration images were taken with steps of 6
µm. The calibration grid had a pitch of 100 µm. The optics consists of a 5x microscope objective
lens working in air and a cylindrical lens with focal length of 300 mm placed in front of the camera
sensor.
Load the experimental images
●
●
●
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From the main menu go to “Project > Load Images…”.
Select the folder “..\GDPTlab_examples\WalkThroughExample2\Data\”.
Select all the images (ctrl+a) and press open.
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Now that you are familiar with the software, create directly the calibration and scaling for your
experiment.
Create your calibration
●
●
●
●

From the main menu go to “Calibration > Create Calibration…”.
Go the folder “..\GDPTlab_examples\WalkThroughExample2\Calibration\”.
Select all the images (ctrl+a) and press open.
Try to create the calibration yourself! Repeat the steps in WTE1.
○ Try different parameters for segmentation and tracking. Use “Refresh” to see the
results.
○ Press “Run” to process all the images.
○ If you get enough valid particles (here you have only two), give a name to your
calibration and push “Make cal”.
○ Don’t forget to put the right “Scale Z” (look at the experiment description).

Your results should now look something like this:
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●

23

If you get different results, try again using these settings:
○ Gauss filter: 5x5  Median filter: 3x3
○ Segmentation: 125  Min Area: 100
○ Scale Z = 6.65
○ Name = cal_WTE2
○ Run > Make Cal > Select all

GDPTlab User Guide v1

NOTE: Why are only two particles good here? As you see there are some particles that are
suspended in the fluid at different height. This is clear in the summary plot when you see one
particle “shifted” at a different height. Additionally, you have some overlapping particles that are
not good for the evaluation. You can see that these particles have a lower correlation factor
(lower than 0.95).
Create xyscaling
●
●
●
●
●
●
●

From the main menu go to Calibration > Scaling… .
Go the folder “..\GDPTlab_examples\WalkThroughExample2\Grid\”.
Select the image “Grid_100um.tif”.
Find the cross and adjust the acceptance sensibility.
Insert the grid pitch (see experiment description) and calculate the grid.
You should get a scale of 1.2154 µm/px in X and 1.2737 µm/px in Y. Remember that in
this case astigmatic optics has been used resulting in Scale X ≠ Scale Y.
Don’t forget to push “Take Values” at the end!

Run the GDPT evaluation.
●
●
●
●
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Load the calibration.
Try to adjust the parameters by yourself. Use “Refresh” to see the results. Remember to
enable “Depth determination” and to set the “Tracking” option to “TimeSeries”.
Once you are satisfied with your settings, give a name to your dataset and press “Run”!
Compare your results with the following figures:
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Are your results similar to the ones of the image?
● If the answer is yes, congratulations! You now are ready to perform your own GDPT
experiments!
● If the answer is no, try again!
● If you still get bad results, use the following settings and try again:
○ Segmentation: 150  Min Area: 100
○ Load calibration cal_WTE2
○ Tracking: time series
○ DX = [5 15]
○ DY = [10 10]
○ DZ = [20 20]
○ Name = dat_WTE2
DRILL: try to plot the trajectory with largest number of points! One possible way is to create the
following script:

26

GDPTlab User Guide v1

5 MISCELLANEOUS
5.1 Processing bright field images
GDPTlab can use only images with dark background and bright
particles. This type of images is normally obtained using
epifluorescence systems or dark field microscopies. If you have
dark particles with a white background, you can still use GDPTlab,
but you have to preprocess the images in order to invert the pixel
intensity. This can easily be done in many image processing
softwares.
See the example on the right: The original image was taken using
a conventional bright field microscope. The image has been
transformed using the software ImageJ, applying the function
Edit>Invert. The new image can be processed by GDPTlab. Using
fluorescent images is advised anyway to get better contrast and
resolution.

Bright field image

Inverted bright field image

5.2 Distortion and perspective errors
Distortion
occurs when the image is not a rectilinear projection of
the scene (i.e. straight lines are not straight in the image  top
image). This may affect the defocusing pattern as well.
Perspective errors
occur when the magnification is changing
through the depth of the measurement volume (bottom image).

Distortion

In case of microscopy (large magnifications), these effects are
normally negligible. For other applications, the perspective errors
can be relevant and proper corrections or mapping functions must
be used.
The current version of GDPTlab does not provide tools to account
for this.
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Perspective error
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5.3 Center of defocusing particle images vs. center of real particles
The GDPT technique assigns the 
xy
position of the particles based on the central position of the
corresponding defocused image. This will not necessarily correspond to the center of the real
particle. However, in most cases the defocusing patterns are symmetric with respect to the vertical
and horizontal axis, therefore this approximation holds. If nonsymmetric particle images are
present, this effect can produce bias error that should be corrected.
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